We're seeing issues with the app
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 13:28 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2024 - 13:07 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2024 - 13:01 GMT
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Mar 26, 2024 - 12:42 GMT
This incident affected: 📱 Cuvva App.